Deprecated: Function eregi() is deprecated in /var/www/web100515/html/mainfile.php on line 88

Deprecated: Function set_magic_quotes_runtime() is deprecated in /var/www/web100515/html/includes/mx_system.php on line 31
Serverboard Forum - Richtige Nutzung von minEVersion in 16.41 ?
Willkommen bei eD2K-Serverboard
Suchen
Artikel
  · Registrieren/Einloggen Portal  ·  Artikel  ·  Artikel schreiben  ·  Lugdunix-/Eselforum  ·  Forum II  ·  Ausloggen  

  Hauptmenü
General
 Home
 Themen
 Artikel
 Downloads
 Links
 Bildergallerie
 Impressum

Community
 Ihr Account
 Memberliste
 Artikel schreiben
 Kalender
 Statistiken

Stuff
FAQ

Suchen

  Zusatz Menü

  
Heute haben keine Benutzer Geburtstag!

  Neue Downloads

Neue Downloads
Neue Downloads ]


  
1: +++ www.eMuleSite.de +++
   [Visits: 2410 x]
2: Windowsforum
   [Visits: 2156 x]
3: Turboforum
   [Visits: 2143 x]
5: Linux-Club
   [Visits: 1929 x]
6: Das Linuxbuch
   [Visits: 1893 x]
7: adslforum bei G. Schwarz
   [Visits: 1877 x]
8: Das eMule - Handbuch
   [Visits: 1812 x]
9: Atelier Web Remote Commander
   [Visits: 1765 x]

  Terminkalender
Juli 2020
  1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
 
Keine Termine fuer heute.

Termin vorschlagen Termin vorschlagen

  Menü II

Flatbooster


Serverboard Forum Sie sind nicht eingeloggt


Nach unten
« vorheriges  nächstes »
Aufsteigend sortiern Absteigend sortieren      print
Autor: Betreff: Richtige Nutzung von minEVersion in 16.41 ?
Junger Esel
Junger Esel

CZmokIllegal
Beiträge: 20
Registriert: 13/10/2003
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 08:57  
Hallo zusammen !

Also ich habe folgendes Problem !

IhmSelbst hat mir ja die Standarddefinitionen bereits gepostet, aber sind die foglenden Angaben richtig, wenn ich nur eMule ab Version 03 zulassen möchte ?

minEversion=0x30
trackbademule=30
trackemule=1

Habe die Sache mit der MinEVersion nicht gecheckt ! Soll ich da jetzt immer =0xVersion des eMule hinschreiben oder einfach nur =Version ?
Was sagt Trackbademule eigentlich aus ?

Bitte nicht die Standarddefinition, denn die kenn ich in und auswendig !


Quelltextbereich einfügen:
minEVersion (integer)
Zusammen mit dem trackemule Feature genutzt. Die älteste Emuleversion die der Server erlaubt. Die Emuleversion ist ein Hexadezimalwert zwischen 00 und FF. Standardwert: 0x24

trackbademule (integer)
Eine Bitmaske von flags. Siehe minEVersion Parameter. Standardwert = 30

trackemule (integer)
Wenn auf 1 gesetzt spürt Eserver die Emuleverion auf. Standard = 1



Ahso, vergessen, kann man nicht die Botuser bannen ?
Und welche Einstellungen brauche ich, um nur die eMule-Versionen ab 0.30, Hybrid ab 0.47.0 sowie die alten Eselversionen, zuzulassen !

Gr33tz CZmok ! ;)

[Editiert am 15/10/2003 von CZmokIllegal]
Profil anzeigen Homepage besuchen Nach allen Beiträgen dieses Users suchen
Esel
Esel

Bollemichel
Beiträge: 68
Registriert: 30/12/2002
Status: Offline
Geschlecht: männlich
red_folder.gif erstellt am: 15/10/2003 um 10:03  
Hi CZmok,

ich habe das mit der Muleversion mal mit der Linux-Variante getestet. Das dürfte aber auch mit der Win-Version funzen.

Bei der Eingabe in der Konsole bzw. bei der festen Einstellung in der donkey.ini habe ich eingegeben:

minEVersion=30

wenn ich dann mit vo all den Status abrufe, zeigt er dann unter diesem Wert den Hex-Wert an. Ich nehme also an, dass das Teil die Umrechnung automatisch vornimmt.
Wenn du hier den Wert 0x30 eingibst, erkennt das Proggi diesen Wert nicht und stellt den vorgegebenen Wert von 0x24 ein.
Allerdings habe ich bei der eingabe von vc nun doch einige 28er Mules gesehen.
Das konnte ich dann soweit abschalten in dem ich noch die Option

only_zlib_clients=true

eingefügt habe.

In der Folge waren dann nur noch Mules ab der Version 30 auf dem Server.
Ich nehme aber an, dass diese Funktionen nur die Mulis betreffen und nicht die guten alten Esel. So konnte ich diverse 6oer Versionen ohne Zusatz und auch 61er als Clienten weiter bedienen.

Um die Hybriden auch noch zu berücksichten, habe ich noch

maxVersion=99999

eingestellt.

Diese Einstellungen haben dann natürlich zu einer ziemlich geringen Anzahl von Clients auf dem Server geführt. Und trotzdem war nach 2h die Leitung dicht (ADSL 768/128).

Gruss
Bolle

[Editiert am 15/10/2003 von Bollemichel]


____________________
Profil anzeigen E-mail senden Nach allen Beiträgen dieses Users suchen Antwort 1
Junger Esel
Junger Esel

CZmokIllegal
Beiträge: 20
Registriert: 13/10/2003
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 10:34  
Okay, also minEVersion=30 !
Aber was bedeutet Trackbademule=???? ?

Also können mit deinen Einstellungen nun die alten Esel v60/v61, die Hybriden und die eMule ab 0.30 bei Dir connecten ?

Gr33tz & THX, CZmok ! ;)
Profil anzeigen Homepage besuchen Nach allen Beiträgen dieses Users suchen Antwort 2
Alter Esel
Alter Esel


Beiträge: 137
Registriert: 30/12/2002
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 10:42  

Zitat:
Also ich habe folgendes Problem !


Deine Probleme möchte ich haben *g*


Zitat:
sind die foglenden Angaben richtig, wenn ich nur eMule ab Version 03 zulassen möchte ?

minEversion=0x30
trackbademule=30
trackemule=1


Setz Trackbademule=1, dann werden die emules direkt gekickt.
Mit =30 gibt's Warnmeldungen und so ein volles Programm - überflüssig *g*

Zitat:
Ahso, vergessen, kann man nicht die Botuser bannen ?


Nee, mit den 16.40ern nicht mehr.
Überflüssig, mit diesem credit-system (smart-sources) der Lugdunum-Server.


____________________

http://www.baracus.de
Profil anzeigen Nach allen Beiträgen dieses Users suchen Antwort 3
Junger Esel
Junger Esel

CZmokIllegal
Beiträge: 20
Registriert: 13/10/2003
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 10:45  
THX ! Supi, werde ich heute Abend gleich testen ...

Gr33tz
Profil anzeigen Homepage besuchen Nach allen Beiträgen dieses Users suchen Antwort 4
Junger Esel
Junger Esel

CZmokIllegal
Beiträge: 20
Registriert: 13/10/2003
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 14:04  
Selbst wenn ich only_zlib_clients=true setze, kann ich mit dem Hybriden connecten, also müsste der neue Hybrid zlib unterstützen ! Ich denke das lediglich die alten eMule und alten eDonkeys dieses Feature nicht unterstützen !
Oder aber diese Funktion funzt ned oder betrifft wirklich nur die eMule Versionen !

Über eine Aufklärung würde ich mich freuen.

Gr33tz CZmok ! ;)

[Editiert am 15/10/2003 von CZmokIllegal]
Profil anzeigen Homepage besuchen Nach allen Beiträgen dieses Users suchen Antwort 5
Alter Esel
Alter Esel


Beiträge: 137
Registriert: 30/12/2002
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 14:14  

Zitat:

Um die Hybriden auch noch zu berücksichten, habe ich noch

maxVersion=99999

eingestellt.



Hm, wieso das?
Die Hybriden identifizieren sich doch auch als 60 oder 61er ...


____________________

http://www.baracus.de
Profil anzeigen Nach allen Beiträgen dieses Users suchen Antwort 6
Alter Esel
Alter Esel


Beiträge: 137
Registriert: 30/12/2002
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 14:38  

Zitat:

Bei der Eingabe in der Konsole bzw. bei der festen Einstellung in der donkey.ini habe ich eingegeben:

minEVersion=30

wenn ich dann mit vo all den Status abrufe, zeigt er dann unter diesem Wert den Hex-Wert an. Ich nehme also an, dass das Teil die Umrechnung automatisch vornimmt.
Wenn du hier den Wert 0x30 eingibst, erkennt das Proggi diesen Wert nicht und stellt den vorgegebenen Wert von 0x24 ein.


Habe das auch gerade nochmal getestet,
minEVersion=0x30 in der donkey.ini wird bei mir einwandfrei angenommen,
wenn Du nur "=30" eingibst sollte es eigentlich NICHT klappen...


____________________

http://www.baracus.de
Profil anzeigen Nach allen Beiträgen dieses Users suchen Antwort 7
Esel
Esel

Bollemichel
Beiträge: 68
Registriert: 30/12/2002
Status: Offline
Geschlecht: männlich
red_folder.gif erstellt am: 15/10/2003 um 15:09  

Zitat:

Zitat:

Um die Hybriden auch noch zu berücksichten, habe ich noch

maxVersion=99999

eingestellt.



Hm, wieso das?
Die Hybriden identifizieren sich doch auch als 60 oder 61er ...


Hi Sucarab,

den Tipp habe ich aus einem Posting von Firstsense entnommen:

http://f25.parsimony.net/forum63199/messages/180463.htm

Das mit der Versionseintragung muss ich mir nochmals anschauen. Erinnerlich war die Ausgabe bei der Eingabe von 30 = Hex 0x1a

Bolle


____________________
Profil anzeigen E-mail senden Nach allen Beiträgen dieses Users suchen Antwort 8
Alter Esel
Alter Esel


Beiträge: 137
Registriert: 30/12/2002
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 15:23  

Zitat:

den Tipp habe ich aus einem Posting von Firstsense entnommen:

http://f25.parsimony.net/forum63199/messages/180463.htm




Kenn ich, das posting... Halte ich aber für falsch.
Würde ja bedeuten, das man auch immer massig abgewiesene clients aufgrund "maxClients" angezeigt bekommen müsste...
Werde sicherheitshalber aber mal lugdunum fragen.


____________________

http://www.baracus.de
Profil anzeigen Nach allen Beiträgen dieses Users suchen Antwort 9
Junger Esel
Junger Esel

CZmokIllegal
Beiträge: 20
Registriert: 13/10/2003
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 15:26  
Also mal langsam Leute !

Wenn ich bei mir in der donkey.ini jetzt folgende Einträge vornehme

MinVersion=60 (steht für eMule und eDonkey v60 ?)
MaxVersion=61 (steht für alle Hybriden und eDonkey v61 ?)
MinEVersion=30
trackbademule=1
trackemule=1
only_zlib_clients=true
LowID=0
LowIDPercent=10

kann ich mit meinem Hybrid 0.50.8 connecten und auch eMule 0.30 !
Andere Clients habe ich nicht gesehen, aber wieso kann ich mit einem Client connecten der kein zlib unterstützt ? Also mit meinem Hybrid !
Ich werde natürlich später im Betrieb diese Funktion rausnehmen, aber wollte das mal testen ... Ist dieses Feature nur für eMule-Clients ?

Gr33tz CZmok ! ;)
Profil anzeigen Homepage besuchen Nach allen Beiträgen dieses Users suchen Antwort 10
Alter Esel
Alter Esel


Beiträge: 137
Registriert: 30/12/2002
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 16:05  

Zitat:
Ist dieses Feature nur für eMule-Clients ?

Gr33tz CZmok ! ;)


Jo, mit diesen EInstellungen können die Hybriden connecten und nur emules mit zlib ...

PS: Mit LowID=0 lässt Du ja gar keien druff, dann ist
LowIDPercent=10 eigentlich überflüssig ;-)


[Editiert am 15/10/2003 von Sucarab]


____________________

http://www.baracus.de
Profil anzeigen Nach allen Beiträgen dieses Users suchen Antwort 11
Junger Esel
Junger Esel

CZmokIllegal
Beiträge: 20
Registriert: 13/10/2003
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 16:14  
Okay, mit der LowID haste recht, das war ja nur test und so musste ich nur eine Sache in der .ini ändern ... *fg* ! Bin halt faul, lol !

gr33tz


____________________
Profil anzeigen Homepage besuchen Nach allen Beiträgen dieses Users suchen Antwort 12
Alter Esel
Alter Esel


Beiträge: 137
Registriert: 30/12/2002
Status: Offline
red_folder.gif erstellt am: 15/10/2003 um 22:21  

Zitat:
den Tipp habe ich aus einem Posting von Firstsense entnommen:

http://f25.parsimony.net/forum63199/messages/180463.htm


sO, habe Lugdunum drauf angesprochen:


That's not true

This edonkey versions use v60 or V61 when connecting to a server.

maxVersion=2000, on razorback catched no client with a version greater than
2000, out of 46679332 total connections. (0 maxVersion in debug output)


debug

215 clients in setup, 46679332 users accepted (4056915 zlib) (216322 emule)
UDP : 64418 slowsearches, 0 denied, 5692 skipped, 129579 sleeps
63128021 extended GetSources
TCP : 1386979181 filegiven, 57662 slowsearches, 9067 sleeps
File hash tab : 1746517 slots
Keyw hash tab : 166021 slots
slimit : 106792 jigle
delwrite : 11089 headcnt, lastrun = 1066218620, runcnt =1305692582,
ldelay=10
ZLIB : 16 blocs, total 116664 bytes allocated
rejects : 20929 minVersion, 0 maxVersion, 23513004 lowids, 9834363
blacklisted, 398 ipfilter, 19653691 full, 5792128 bademule, 297059 zlibonly,
18636 hardlimit
2165089 disconnects because IP:port clash
MEM : gmallocmem=515899392, file memspace = 760006564, kcells=385601304
9834761 fd were put in blackhole (age : 4924 secs)



____________________

http://www.baracus.de
Profil anzeigen Nach allen Beiträgen dieses Users suchen Antwort 13
Junger Esel
Junger Esel

CZmokIllegal
Beiträge: 20
Registriert: 13/10/2003
Status: Offline
red_folder.gif erstellt am: 16/10/2003 um 12:39  
Okay, THX !


____________________
Profil anzeigen Homepage besuchen Nach allen Beiträgen dieses Users suchen Antwort 14
« vorheriges  nächstes »        print
Nach oben


mxBoard, © 2006 by pragmaMx.org, based on eBoard, XMB and XForum


-
Alle Logos und Warenzeichen auf dieser Seite sind Eigentum der jeweiligen Besitzer und Lizenzhalter.
Im übrigen gilt Haftungsausschluss. Weitere Details finden Sie im Impressum.
Die Artikel sind geistiges Eigentum des/der jeweiligen Autoren, alles andere © 2003 - 2007 by eD2K-Serverboard
Diese Webseite basiert auf pragmaMx 0.1.9. Dieses CMS ist frei erhältlich.